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LAB MANUAL
CREATION OF ADDITION WEB SERVICE:

Aim:

To create a web service for adding few numbers using NetBeans.

Algorithm:

1. Using the Netbeans API create a project of the type web application.

2. Create a web service in the project.

3. Click on the Design tab and design the prototype of the web service.

4. Click on source tab and modify the application logic of the web service.

5. Save the project.

6. Right click on the project and click on deploy and undeploy.

7. Then test the web service.

STEPS TO CREATE ADDITION WEB SERVICE:
I.STEPS FOR CREATING SERVER SIDE PROJECT:

1.OPEN File->New->NewProject->Web->Web App..click next
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2.Give Project name->addserver…then click finish

[image: image3.png]P KPNBusTravels - NetBeans IDE 6.1 Beta

Fle Edt Vew Navigate Source Refactor Buld Run Profle Versioning Tooks Window Help

PEHES XSO TH>BR-G-

@ %] Files services | [[B) index.isp x | (B] actionn.jsp_x ] [B) bus_actionjsp x| () KPNBusTravelsWS.java_x DIEEE w |
i B8 awsEfee auen e
addserver = 3 Table
® annda BN ® New Web Application = BB ordered
@ ashokarotel S — -
& e B stens - orcr
g <
g et e Choose Project Project Name: | acerver] ]
Hitonrote “ea ] 2 Nameandtocation n class=rsti
glaqsan /e Sharabilty Project Location; | C:\Documents and Settings\HOSTUSER{My DocumentsifetBeansProjects
Jethirways S—
- B <ee> [ 9 Project Folder: [Ci{pocuments and SettingsIHOSTUISER My Documents{etBeansPrajectsiaddserver
aq
@ Qos_Clent <
<ta
© Ratondattel L e o Erterpre At [ <t

@ smcartravels
@ smcartaves servr [Gserihvz

@ souherntraves

@ sunTravels 3 Java EE Version: |JavaEE S

© Trovels Conort Pt [Joerver

“bus_action.jsp - Navigator 41 x

I£3

riers: [0 [ @)@ szt |ms

Output Set as Main Project

D> | GlassFish ¥2 x | Retriever Output x| cientt (run)x

I iy vo crasve reference for sppiiearid
Teying vo stere spplicavion i carger se
Deployaent. of spplication eliensl coaple
run-dsploy:

Eroveing: bep: //localhost: 5080/ cliensl/
run-aispLay-brovsar

BUILD SUCCESSFUL (total sine: 2 saconds)

@ Project Folder already exists and is not emty.

[E3





3.The addserver project will be created in right side.Right click it and choose the following.

Give the web service name as addweb.
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4.After this in left side ,the design window choose the add operation 
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5. Give the following in the opened window for creating operation

Name->add

[image: image6.png]Fle Edt Vew Navigate Source Refactor Buld Run Profle Versioning Tooks Window Help

BABEDE THDPBR-G-

index.p x| B actomn s x| ) bus_sctionsp x| [0 KeNBusTravelowS ava | [0 scwebjsva =]

B x

B .@ adone 2| source [ pesion | [ [ [0 v]@ @ @

@ webpages
©-@ web service References

addwebService

addnebservice
G Configuration Files
@ server Resources
@ source Packages
@ Test Packages
@ ubraries
@ TestLbraries
5@ adiserver
@ webpages
S-@ webservices

[ addneb add
G Configuration Files —
@ server Resources
@ source Packages
@ Test Packages
@ ubraries &
< I =

‘addwebjava- Navigator 41 x

Operations

(=) add Name: [add

Retun Type: javalang.tring Erowse,

Parameters

Parameters | Exceptons|

Quality Of Service

- Optimize Transfer Of Binary,

7 Reliable Message Delivery

© Secure Service

web Service Design v

brameter Type

ElE]E]

Description

Output

DD | Glassish v2 x | Retrisver Output x| clentt (run)x

B ing ta crasve refarence for sppiicasion in terses o9
conpleted mmcerztally

Trying to starc application in target server
Deployment of spplicavion clisntl complsted succsssfully
run-deploy:

Browsing: hrep://localhost:8080/clisntl/
run-aisplay-brovser

BUILD SUCCESSFUL (cotal cime: 2 seconds)|

[E3





6.Then in the source add the following code and save it.

package org;

import javax.jws.WebMethod;

import javax.jws.WebParam;

import javax.jws.WebService;

@WebService()

public class addweb {

    /**

     * Web service operation

     */

    @WebMethod(operationName = "add")

    public int add(@WebParam(name = "a")

    int a, @WebParam(name = "b")

    int b) {

        int k=a+b;

        return k;

    }

}

7.Then right click on add addserver and perform undeploy and deploy…after that right click on addweb and do test web service to see the SOAP request and response message. 
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Give some integers and click add.
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CREATION OF WEB SERVICE CLIENT

Aim:

To create a web service for adding few numbers using NetBeans and write client side code to invoke the web service.

Algorithm:

1. Using the Netbeans API create a project of the type web application.

2. Create a web service in the project.

3. Click on the Design tab and design the prototype of the web service.

4. Click on source tab and modify the application logic of the web service.

5. Save the project.

6. Right click on the project and click on deploy and undeploy.

7. Then test the web service.

8. Create another web application project and create a jsp file.

9. Right click on project and click on create web service client.

10. Browse and choose the web service created i.e wsdl url

11. Drag and drop the web service reference to the source code window.

12. Then pass the appropriate parameters to the web service client and invoke the web service.

STEPS TO CREATE CLIENT SIDE PROJECT:
1.create the new project as above and give the name as addclient.
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2. addclient project will be created. right click it and choose the following.
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3.Then browse and choose the addweb wsdl file
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4.Then choose the following and add the source code in index.jsp and save it.
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Index.jsp source code

<%@page contentType="text/html" pageEncoding="UTF-8"%>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

   "http://www.w3.org/TR/html4/loose.dtd">

<html>

    <head>

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

        <title>JSP Page</title>

    </head>

    <body>

        <h1>Hello World!</h1>

        <form name="" action="actionn.jsp" method="post">

 Enter 1st No:<input  name="fst" type="text" /><br/>

Enter 2nd No:<input  name="snd" type="text" /><br/>

 <input  name="ok" type="submit" value="Add" />

</form>

    </body>

</html>

5.Then create an action.jsp as follows.

Right click web page in addclient and choose new->jsp
Name:action

Click finish
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6.click on the actionn.jsp  page..then right click in it and choose web service client reference ->call web service
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7.The invoke the add service.
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8. add the following code in the action.jsp 

<%@page contentType="text/html" pageEncoding="UTF-8"%>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

   "http://www.w3.org/TR/html4/loose.dtd">

<html>

    <head>

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

        <title>JSP Page</title>

    </head>

    <body>

        <h1>Hello World!</h1>

         <%

 String a1=request.getParameter("fst");

String b1=request.getParameter("snd");

int aa=Integer.parseInt(a1);

int bb=Integer.parseInt(b1);

  %>       

    <%-- start web service invocation --%><hr/>

    <%

    try {


org.AddwebService service = new org.AddwebService();


org.Addweb port = service.getAddwebPort();


 // TODO initialize WS operation arguments here


int a = aa;


int b = bb;


// TODO process result here


int result = port.add(a, b);


out.println("Result = "+result);

    } catch (Exception ex) {


// TODO handle custom exceptions here

    }

    %>

    <%-- end web service invocation --%><hr/>

    </body>

</html>

8.finally undeploy and deploy the addclient and run it.
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CREATION OF A WEB SERVICE WITH DATABASE CONNECTIVITY
Aim:

To create a web service for adding few numbers using NetBeans and write client side code to invoke the web service.

Algorithm:

1. Using the Netbeans API create a project of the type web application.

2. Establish connectivity with the database along with the necessary authentication parameters.

3. Create a web service in the project.

4. Click on the Design tab and design the prototype of the web service.

5. Click on source tab and modify the application logic of the web service.

6. Save the project.

7. Right click on the project and click on deploy and undeploy.

8. Then test the web service.

9. Create another web application project and create a jsp file.

10. Right click on project and click on create web service client.

11. Browse and choose the web service created i.e wsdl url

12. Drag and drop the web service reference to the source code window.

13. Then pass the appropriate parameters to the web service client and invoke the web service.

STEPS FOR CREATING TRAVEL WEB SERVICE

Requirements:

->Mysql

->netbeans with glass fishv2 server

I.Before creating project in net beans do the following:

1.install Mysql setup file and the gui tools .

2.Then open the mysql browser in the start->programs->mysql->mysql browser
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Then restore the back up(newproject2011…) as follows

1.choose  tools->mysql administrator

2.Then choose restore in that window..Then click open backup in the bottom…open the backup file(newproject201….) which is in the attachment….then click start restore..
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3.now the  schema is created in the mysql…..

Now strat the coding in netbeans…

SERVER SIDE:

1.create the server project as before and with the following changes. 

Project name: KPNBusTravels

2.web service name:KPNBusTravels

Package name:kpnpack

3.in design window

Operation name:getBus

Parameters:

Source and destination with the type as String.

4.Add the following code in source

package kpnpack;

import java.sql.Connection;

import java.sql.DriverManager;

import java.sql.ResultSet;

import java.sql.Statement;

import java.util.ArrayList;

import java.util.Hashtable;

import javax.jws.WebMethod;

import javax.jws.WebParam;

import javax.jws.WebService;

/**

 *

 * @author user

 */

@WebService()

public class KPNBusTravelsWS {

    /**

     * Web service operation

     */

    @WebMethod(operationName = "getBus")

    public String getBus(@WebParam(name = "source")

    String source, @WebParam(name = "destination")

    String destination) {

        //TODO write your implementation code here:

        ArrayList<String> service_name = new ArrayList<String>();

        ArrayList<String> departure_time = new ArrayList<String>();

        ArrayList<String> arrival_time = new ArrayList<String>();

       ArrayList<String> bus_fare = new ArrayList<String>();

      ArrayList<String> bus_type = new ArrayList<String>();

      ArrayList<String> bus_category=new ArrayList<String>();

       try {

       Class.forName("com.mysql.jdbc.Driver");

       Connection con=DriverManager.getConnection("jdbc:mysql://localhost:3306/qos","root","root");


  Statement st1=con1.createStatement();

                st1.executeUpdate("insert into qostable(webname, exetime,price,compute,availtime) values('"+wn+"','"+et+"','"+pr+"','"+ct+"','"+at+"')");

        Statement st=con.createStatement();

            ResultSet rs = st.executeQuery(sql);

              int i=0; 

            while (rs.next()) {

              departure_time.add(rs.getString(3));

              arrival_time.add(rs.getString(4));

              bus_fare.add(rs.getString(5));

               bus_type.add(rs.getString(9));

               bus_category.add(rs.getString(11));

               service_name.add(rs.getString(12));

             //  service_name.add(rs.getString("Servicename"));

            }

         } catch ( Exception e) {

            e.printStackTrace();

        }

        String concatBus = service_name.toString()+"&"+departure_time.toString()+"&"+arrival_time.toString() +"&"+bus_fare.toString() +"&"+

               bus_type.toString() +"&"+bus_category.toString() +","; 

        return concatBus;

    }

}

5.Then deploy the service and test the web service as before.

Give input as Chennai and Coimbatore .then click getbus.
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CLIENT SIDE:

1.create new project

Name:client1

2.As before in addition program create web service reference.

3.The source code for index.jsp and action,jsp are as follow.

Index.jsp:

<%@page contentType="text/html" pageEncoding="UTF-8"%>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

   "http://www.w3.org/TR/html4/loose.dtd">

<html>

    <head>

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

        <title>JSP Page</title>

    </head>

    <body>

        <h2>Hello World!</h2>

        <form name="" action="actionn.jsp" method="post">

 Enter Source:<input  name="source" type="text" /><br/>

Enter Destination:<input  name="destination" type="text" /><br/>

 <input  name="ok" type="submit" value="" />

</form>

    </body>

</html>

Action.jsp

<%@page contentType="text/html" pageEncoding="UTF-8"%>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"

   "http://www.w3.org/TR/html4/loose.dtd">

<html>

    <head>

        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

        <title>JSP Page</title>

    </head>

    <body>

        <h2>Hello World!</h2>

         <%

 String a1=request.getParameter("source");

  String b1=request.getParameter("destination");

  %>

    <%-- start web service invocation --%><hr/>

    <%-- end web service invocation --%><hr/>

    <%-- start web service invocation --%><hr/>

    <%

        String[] res,commasplit=null,lbrsplit=null,rbrsplit=null;  

       String[][] flight_trans=new String[100][100];

        int row=0,col=0;

        int trow=0,tcol=0;

        int midrow=0,midcol=0;

        // Jagson

       String[] jagres,jagcommasplit=null,jaglbrsplit=null,jagrbrsplit=null;  

       String[][] jagflight_trans=new String[100][100];

        int jagrow=0,jagcol=0;

        //Air India

        String[] airres,aircommasplit=null;  

       String[][] airflight_trans=new String[100][100];

        int airrow=0,aircol=0;

       try {


kpnpack.KPNBusTravelsWSService service = new kpnpack.KPNBusTravelsWSService();


kpnpack.KPNBusTravelsWS port = service.getKPNBusTravelsWSPort();


 // TODO initialize WS operation arguments here


java.lang.String source = "a1";


java.lang.String destination = "b1";


// TODO process result here


java.lang.String result = port.getBus(source, destination);


out.println("Result = "+result);

            res=result.split("&");

        System.out.println("Jet Split:"+res);


for(int i=0;i<res.length;i++)

            {

                int j=0;

            row=res.length;

            String lbr=res[i].replace("[", "");

            String rbr=lbr.replace("]", "");

            commasplit=rbr.split(",");

            for( j=0;j<commasplit.length;j++)

                 {

                 col=commasplit.length;

                 System.out.println("flight_trans[i][j]"+i+"/"+j);

                  if(commasplit[j]!=null)

                 flight_trans[j][i]=commasplit[j]; 

                  }

           // if( flight_trans[i][j]==null)

               // col=0;

            } 




// out.println("Res = "+res[0]);

           System.out.println("TR");

           System.out.println("jetRow:"+row);

            System.out.println("jetColumn:"+col);

          for(int r=0;r<row;r++)

              {

               for(int c=0;c<col;c++)

                   {

                   if(flight_trans[r][c]!=null)

                   System.out.print("tr:"+flight_trans[r][c]);

               }

               System.out.println();

          }

    } catch (Exception ex) {


// TODO handle custom exceptions here

    }

    %>

    <%-- end web service invocation --%><hr/>

    </body>

</html>

4.Then finally undeploy and deploy the client and run it……………..

CREATION OF A BPEL MODULE AND A COMPOSITE APPLICATION
Aim:

Create a SOA project with BPEL Module to compose a web service.

STEPS TO CREATE A BPEL MODULE

Creating a new BPEL Module Project

The following sections use the Synchronous sample project, and provide step-by-step directions for creating a simple BPEL module project, using the Synchronous sample project.
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To Create a BPEL Module Project

1. In the NetBeans IDE, choose File > New Project. 

The New Projects wizard appears. 

2. Under Categories, select Service Oriented Architecture.

3. Under Projects, select BPEL Moduleand click Next.
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4. In the Name and Location page, enter the project name (for this example HelloWorld) and specify the project location or accept the defaults.
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5. Click Finish.

The Projects window now contains a project node for the BPEL Module project.
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Creating a BPEL Process Using the BPEL Designer

Now that you have created your XML Schema and WSDL Document, you can create your BPEL process.

To Create the BPEL Process

1. In the Projects window, expand your BPEL module project node, right-click the Process Files node, and choose New -> BPEL Process.

The New BPEL Process dialog box appears.
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2. Enter a name for the process file name (HelloWorldProcess for this example), and click Finish.

The new BPEL file opens in the Design view of the BPEL Designer.

If the Palette and Properties windows are not displayed in your current view, click Windows -> Reset Windows on the NetBeans menu.
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3. Add a partner link to the BPEL Process.

a. In the Projects window, expand your project's Process Files node and select the .wsdl file (Synchronous.wsdl for this example).

b. Drag the WSDL file from the Projects window to the left side of the Design view canvas.

The IDE provides visual prompts to show you where you can drop the selection. 

The BPEL Editor adds a partner link to the canvas.
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4. Add a Receive activity to the BPEL Process.

a. From the Web Service section of the Palette window, select the Receive activity. 

b. Drag the Receive activity to the HelloWorldProcess process box in the Design view canvas, between the Process Start and the Process End activities.

The Receive1 activity is added to the process box.

c. Click the Receive1 activity's Edit icon.

The Receive1 Property Editor appears.

d. On the Main tab, change the value in the Name field to start.

e. From the Partner Link drop-down list, choose PartnerLink1.

The IDE populates the Operation field with NewWSDLOperation.

f. Click the Create button next to the Input Variable Field. 

The New Input Variable dialog box appears. 

g. Click OK to accept the default values.

h. Click OK to close the Receive1 Property Editor. 

The Design view displays the new connection between PartnerLink1 and the Start activity in the process box.
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5. Add a Reply activity to the BPEL Process.

a. Select the Reply activity in the Web Service section of the Palette. Drag and drop the Reply to the prompt between the Start activity and the Process End activity in the process box on the design view canvas.

A Reply1 activity is added to the design view canvas.

b. Click the Reply1 activity's Edit icon.

The Reply1 Property Editor appears.

c. On the Main tab, change the value in the Name field to End.

d. From the Partner Link drop-down list, choose PartnerLink1.

The IDE populates the Operation field with NewWSDLOperation.

e. To create anew output variable, make sure that Normal Response is selected, and click the Create button next to the Input Variable Field. 

The New Input Variable dialog box appears. Click OK to accept the default values.

f. Click OK to close the Reply1 Property Editor. 

The Design view displays the new connection between the End activity in the process box and PartnerLink1.
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6. Add a Assign activity to the BPEL Process.

a. Select the Assign activity in the Basic Activities section of the Palette. Drag and drop the Assign to the prompt between the Start activity and the End activity in the process box on the design view canvas.

The Assign1 activity is added to the design view canvas.

b. Select the Assign1 activity and click the Mapper button on the editors toolbar.

The BPEL Mapper appears.

c. Map the paramA node under Variables -> NewWSDLOperationIn -> inputType in the Output pane of the BPEL Mapper, to the paramA node under Variables -> NewWSDLOperationOut -> resultType in the Input pane of the Mapper. To do this, select theparamA node under Variables -> NewWSDLOperationIn -> inputType in the Output pane, and drag your cursor to the paramA node under Variables -> NewWSDLOperationOut -> resultType in the Input pane.

This assignment copies the input statement into the output.
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7. To save your changes click the Save All icon in the IDE menu bar.

Creating a Composite Application Project

A BPEL Module project is not directly deployable. You must first add a BPEL Module project, as a JBI module, to a Composite Application project. You can then deploy the Composite Application project. Deploying the project makes the service assembly available to the application server and enables its service units to run.

To Create a New Composite Application Project

1. Choose File > New Project (Ctrl-Shift-N).

2. In the Categories list choose Service Oriented Architecture, in the Projects list choose Composite Application, and click Next.

3. In the Name and Location page, change the project name to HelloWorldApplication, and specify the location of project files.

4. To set the new Composite Application the main project as main, leave the Set as Main Project checkbox selected, and click Finish.

5. To add the BPEL Module as a JBI module to the Composite Application project, right-click the new Composite Application and choose Add JBI Module. 

The Select Project dialog box opens.

6. Select the HelloWorld project you created earlier and click Add Project JAR Files.

The Select Project dialog box closes and the HelloWorld.jar file is added to the JBI Modules node of the HelloWorldApplication Composite Application

Building and Deploying the Composite Application Project

Building a project compiles the BPEL source file and packages the BPEL file and web service artifacts, including WSDL and XSD files, into a JAR archive. Deploying the project compiles the files in the Composite Application project, packages the compiled BPEL and related web service artifacts (including WSDL and XSD files) into an archive, and deploys them to the Application Server.

To Build and Deploy the Composite Application Project

1. Right-click the Composite Application project's node, and choose Build.

When the build is complete the Output window reports Build Successful. If the Output window is not visible, choose Window -> Output -> Output.

2. Right-click the Composite Application project's node, and choose Deploy.

3. Deployment has succeeded when you see a Build successful message in the GlassFish tab of the Output window.

4. Open the Services window and expand Servers -> GlassFish V2 -> JBI -> Service Assemblies to see your new deployed Service Assembly.

If you do not see the deployed project, right-click the Service Assemblies node and choose Refresh.
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Testing the Composite Application

You can test your Composite Application project by adding test cases, binding to the operation, supplying input, and then using the tester.

Test the HelloWorldApplication Composite Application Project

1. In the Projects window, expand the HelloWorldApplication project node, right-click the Test node, and choose New Test Case.

The New Test Case wizard opens.

2. Accept the default test case name, TestCase1, and click Next.

3. From the Select the WSDL Document page, expand the HelloWorld - Proecss Files node, select Synchronous.wsdl, and click Next.

4. From the Select the Operation to Test page, select the Operation1 and click Finish.

A new TestCase1 node is added under the project's Test node in the Projects window, containing two subnodes, Input and Output. 

The Source Editor appears containing the Input file, Input.xml 



Note – 
If the Source Editor does not contain a tab for Input.xml, double-click the Input node in the Projects window to open the file.



5. From the Input.xml tab of the Source Editor, do the following:

a. Locate the line: 

	<syn:paramA>?string?<syn:paramA>


b. Replace ?string? with Hello World, so that the line appears as follows:

	<syn:paramA>Hello World<syn:paramA>


c. From the NetBeans IDE menu bar, click Save All.
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6. In the Projects window, double-click the Output node under Test -> TestCase1.

Output.xml is opened in the Source Editor. Initially, Output.xml is empty until the first test run populates the file. 

7. In the Projects window, right-click the TestCase1 node and choose Run from the pop-up menu.

When the Overwrite Empty Output dialog box appears, click Yes to accept new output. The first test run populates the Output.xml file displayed in the Source Editor. 
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The test compares the output to the contents of the output file. Because the first run of the test has nothing to compare itself to, the first test fails. Subsequent test runs will compare their output with the contents of Output.xml and should succeed. 

8. Run the test again.

The test case is compared to the current output file and succeeds. 

